Potential issue between our data centres that is impacting all services intermittently for some customers.
Incident Report for iPECS Cloud
Resolved
We are pleased to confirm that service was fully restored across the iPECS Cloud platform at 04:30 AM today following the maintenance carried out overnight. This follows the partial restoration that had been completed by 15:30 on 16th July which had left iPECS Analytics as the only affected service.
Posted Jul 17, 2024 - 09:30 BST
Update
Service has been restored for iPECS ONE, Customer Manager and Reseller Portals, Phone registration and Calls.

A maintenance window to resolve all remaining connection issues has been scheduled as below:
Tuesday 16th July 2024 at 23:00 - 03:00
Posted Jul 16, 2024 - 17:26 BST
Update
We are now seeing service restored for iPECS ONE, Customer Manager and Reseller Portals, Phone registration and Calls.
Posted Jul 16, 2024 - 16:58 BST
Update
We are still continuing to investigate this issue.
Posted Jul 16, 2024 - 13:09 BST
Update
We are continuing to investigate this issue.
Posted Jul 16, 2024 - 12:11 BST
Investigating
We are currently investigating this issue.
Posted Jul 16, 2024 - 11:12 BST
This incident affected: Network, Portals, iPECS ONE, and iPECS Analytics.