Calls failing on ROI trunk
Incident Report for
iPECS Cloud
Resolved
This issue is now resolved.
Posted
Dec
08
,
2025
-
16:59
GMT
Identified
We are aware of an issue affecting calls on the Republic of Ireland trunk. This is being investigated urgently by the carrier. UK trunks are not affecting by this issue.
Posted
Dec
08
,
2025
-
16:10
GMT
This incident affected: Other.
×
Subscribe to Incident
Subscribe to updates for
Calls failing on ROI trunk
via . You'll receive .